Issues with authorizing a subset of first-time buyers

Incident Report for Billie

Resolved

Incident resolved at 12:32
Posted Oct 09, 2025 - 14:30 UTC

Monitoring

At 12:32 a fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 14:29 UTC

Identified

We identified an issue that affects the authorization process for a subset of first-time buyers in cases where no billing address details are received during the authorization request at 11:52.
Posted Oct 09, 2025 - 14:29 UTC