Checkout widget not properly loading

Incident Report for Billie

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 13:36 UTC

Monitoring

The system was rolled back to a previous state and we are monitoring the results
Posted Feb 16, 2026 - 11:18 UTC

Investigating

We are currently investigating an issue related to our checkout widget preventing customers to check out with Billie
Posted Feb 16, 2026 - 10:58 UTC
This incident affected: Billie Checkout (Checkout Widget).